
 
 

Order Number:  329685-001US 
 
 

 
 
 
 
 
 

Intel® Galileo Board 
Getting Started Guide 
 
02 October 2013 
 
 
 
 
 
 
 

 

 

 

 

 

 

 

 

 

 

 

 
 



 
Intel® Galileo Getting Started Guide 

 
 

 
   
2   Order Number:  329685-001US 

Getting Started Guide 
This document explains how to connect your Intel® Galileo board to the computer, 
install the software on your computer, and upload your first sketch.  

Note: This release uses a special version of the Arduino IDE. The first thing you must do is 
download it from the Intel website below and update the SPI flash on the board. 

The basic steps you will follow are:  
1. Get a board and cables 
2. Download the Arduino environment and board firmware 
3. Connect the board 
4. Install the drivers and other software 
5. Launch the Arduino IDE application 
6. Update your board firmware 
7. Open the blink example 
8. Select your board 
9. Select your serial port 
10. Upload the program 
 
See these sections for advanced tasks:  
11. Booting your board from an SD card (mandatory for WiFi)  
12. Manually update your board firmware (optional)  

 

1. Get a board and cables 

The kit contains: 

• 1x Intel® Galileo Customer Reference Board (CRB) (Fab D with blue PCB)  

• 1x 5v power supply with cable    
Warning: you must use a power supply or the board will be damaged!  

• 4x standoff separators 

• 4x screws 

• 1x USB Type A Male to Micro-B Male cable 
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Intel® Galileo Board 

 

Note: The I/O headers are identical to the Arduino Revision 1.0 pinout.  
 

2. Download the Arduino environment and board firmware 

Download the latest IDE and firmware files here: 

https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=23171   

This release contains multiple zip files, including: 

• Operating system-specific IDE packages, contain automatic SPI flash update: 
− Intel_Galileo_v0.7.5-arduino-1.5.3-linux32.tgz 
− Intel_Galileo_v0.7.5-arduino-1.5.3-linux64.tgz 
− Intel_Galileo_v0.7.5-arduino-1.5.3-macosx.zip 
− Intel_Galileo_v0.7.5-arduino-1.5.3-windows.zip 

• (Optional) Files for updating SPI flash manually. See Section 12 for details.  
SPI flash image capsule files:  Intel_Galileo_v0.7.5-capsulefiles.7z  
− CapsuleApp.efi  
− sysimage_0_7_5capsulefull.cap  

• (Mandatory for WiFi) Files for booting board from SD card:   
Intel_Galileo_v0.7.5-meta-clanton_0_7_5.7z  

Note: If you want to use WiFi, you must set up the board to boot from an SD card. 
See Section 11 for details.  

Note: When unzipping the packages:  
− Extract the package into the C:\ directory due to a known issue unzipping 

packages with long file paths.  
− Use an unzip tool that supports an extended file path (for example, 7-zip from 

http://www.7-zip.org/). 

https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=23171�
http://www.7-zip.org/�
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Windows*: 
1. Unzip the IDE file to the C:\ directory.  
2. Make sure to preserve the folder structure. Double-click the folder to open it.  

If you are updating your IDE, be sure to uninstall the previous IDE version first.  

Linux*: 
1. In your home directory, extract the package with the appropriate command: 

tar -zxvf arduino-1.5.3-linux32.tar.gz  
or 
tar -zxvf arduino-1.5.3-linux64.tar.gz 

2. To avoid interference with the IDE, you must disable modem manager. The exact 
command will depend on your Linux distribution.  
For example, the command sudo apt-get remove modemmanager may work.  

3. In the same directory where the package was downloaded, launch the Arduino IDE 
by executing ./arduino 

Note: The first time you run the IDE, you must run it as root due to SDK install file 
permissions using the command: sudo ./arduino  

Mac OS*: 

Caution: You must unzip the IDE on your Mac’s normal hard disk. Once the IDE is 
unzipped, you cannot run it from or transfer it to USB drives or any other 
media formatted for use in Windows computers or it will be corrupted.  

1. Download the zip file on the Mac hard drive and unzip it. 
2. Drag and drop the Arduino application onto the Applications folder on your Mac. 

 

3. Connect the board 

WARNING: You must use the power supply or you will damage the board.  
 
Connect the 5V power cable to the Galileo board and to a power outlet. 

Note: Always connect the 5V power before any other connection.  

The green power LED (labelled PWR) will turn on.  

 

4. Install the drivers and other software 

Windows: 
1. If not done already, connect the 5V power cable to the Galileo board and to a 

power outlet.  

Note: Always connect the 5V power before the USB connection.  

2. Connect the USB cable to the USB Device Port (closest to the Ethernet) and to a 
PC. Wait for Windows to begin its driver installation process. After a few moments, 
the process will fail.  

3. Click on the Start Menu, and open up the Control Panel. While in the Control 
Panel, navigate to System. Next, click on System. Once the System window is 
up, open the Device Manager.  
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4. Look under Ports (COM & LPT). You should see an open port named Gadget 
Serial V2.4  

Note: You may find Gadget Serial 2.4 under Other devices in Device Manager. If 
this is the case, do the following:  

a. Confirm that usbser.sys is missing in C:\Windows\System32\drivers 
b. Copy usbser.sys from the archive location identified below: 

Windows 7: 
C:\Windows\System32\DriverStore\FileRepository\mdmcpq.inf_amd64_n
eutral_fbc4a14a6a13d0c8\usbser.sys   (archive file)  

Windows 8: 
C:\Windows\System32\DriverStore\FileRepository\mdmcpq.inf_amd64_d
9e0b9c4fe044b4d\usbser.sys   (archive file)  

c. Copy to: C:\Windows\System32\drivers  
d. Once usbser.sys is copied, continue with the steps below. 

5. Right-click on the Gadget Serial V2.4 port and choose the Update Driver 
Software option.  

6. Next, choose the Browse my computer for Driver software option.  
7. Finally, navigate to and select the driver file named linux-cdc-acm.inf, located 

in the hardware/arduino/x86/tools directory).  
8. Once the driver is successfully installed, Device Manager will show a 

Gadget Serial (COMx) device under Ports (COM & LPT).  Note the COMx port 
number as it will be needed in the IDE later. 

Linux: 
1.  If not done already, connect the 5V power cable to the board and to a power 

outlet. Wait for the board to boot.  

Note: Always connect the 5V power before the USB connection.  

2. Connect the USB cable to the USB Device Port (closest to the Ethernet) and to a 
PC.  

3. Check that ACM port is available by typing in the terminal ls /dev/ttyACM* 

Note: If the /dev/ttyACM0 port is not present, follow the procedure below: 
a. Create a file etc/udev/rules.d/50-arduino.rules and add the following: 

KERNEL=="ttyACM[0-9]*", MODE="0666"  
b. Restart the udev with the following command: sudo service udev restart 

If you are using a virtual machine (VM), you may need to reboot Linux within 
the VM. 

4. Launch the IDE. If this is the first time you are running the IDE, you must run it as 
root due to SDK install file permissions with the command: sudo arduino  

5. Select your board via Tools > Board > Intel Galileo Fab D 
6. Select the port Tools > Serial Port > /dev/ttyAMC0  

Note: If the serial ttyACM0 is not available, make sure you have the proper rights to 
access the ports. If the serial port is disabled on your IDE, exit the IDE and 
execute again using the command: sudo arduino  
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Mac OS:  

The Galileo board is supported by the Mac OS built-in USB drivers, however, the board 
has to boot for it to show up because the port is driven by software on the board. 
1. If not done already, connect the 5V power cable to the board and to a power 

outlet. Wait for the board to boot. 

Note: Always connect the 5V power before the USB connection.  

2. Connect the USB cable to the USB Device Port (closest to the Ethernet) and to 
your Mac. Check the System Profiler > USB setting to be sure that Gadget 
Serial is selected. If you are installing a new version of the IDE, you may need to 
re-select this setting.  

3. In the Arduino IDE, the correct serial port shows in the Tools > Serial Port menu 
as /dev/cu.usbmodemnnnnn  where nnnnn is a number such as fd121. 

Do not select the /dev/tty port. 
 

5. Launch the Arduino IDE application 

Windows: In the folder arduino-1.5.3, double-click arduino.exe 

Linux: In the folder arduino-1.5.3, launch Arduino by executing ./arduino 

Note: You may see an error stating Java is not present. If you are using Ubuntu, run 
the command sudo apt-get install default-jre to clear this error.  

Mac OS: Double-click the Intel Galileo Install disk image. When the disk volume 
mounts, drag and drop the Arduino application on your Applications folder.  
 

6. Update your board firmware  

The IDE contains the release-specific firmware for your board. Follow the steps below 
to update your board firmware using the IDE.  
1. Remove all power from the board (USB and 5 V power cord). This makes sure that 

no sketch is running on the board. 
2. Remove the SD card from the board (if it is inserted).  
3. Power up the board by plugging in the 5V power supply.  
4. Connect the USB cable to the USB Device Port (closest to the Ethernet).  

Note which COM port it is connected on. 
5. Launch the IDE and select the board via Tools > Board > Intel® Galileo  
6. Select the correct serial port using Tools > Serial Port  

Note: Do not download any sketch to the board before you upgrade the firmware. 

7. Launch the software upgrade using Help > Firmware Upgrade  
8. A message is displayed asking you to confirm that 5V power cable is plugged in. 

Click Yes if it is connected. If no cable is plugged in, exit the upgrade process by 
selecting No, connect the power, and restart this process. 

9. The board can be upgraded to newer software or downgraded to older software. 
The next message displays the current software version that is on the board and 
the software version that you are trying to flash onto the board. Select Yes to 
either Upgrade/Downgrade or flash the same software again. 
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10. The upgrade progress takes about 6 minutes and is displayed in several popup 
messages. During the upgrade process, you will not have access to the IDE.  

Note: The power and USB cables must stay connected during the upgrade process. 

11. When the upgrade completes, a message is displayed stating Target Firmware 
upgraded successfully. Click OK to close the message. 

If you want to flash a different firmware version that is not contained in the IDE, 
download the SPI flash image capsule files as described in Section 2.  

The downloaded capsule should be copied to the following locations, depending upon 
your operating system. Make sure that there is only one *.cap file in the location 
below. If you are downloading a new file, rename the previous *.cap to some other 
extension. 

• Windows: Arduino-1.5.3/hardware/tools/x86/bin/  

• Linux: Arduino-1.5.3/hardware/tools/ 

• Mac OS: Arduino.app/Contents/Resources/Java/hardware/tools/x86/bin/ 

Note: If you see a failure at any stage of the upgrade, refer to the Release Notes for 
known issues and possible workarounds.  
 

7. Open the blink example 

Open the LED blink example sketch: File > Examples > 1.Basics > Blink.  

8. Select your board 

Select Tools > Board > Intel Galileo Fab D.  

Note: If the IDE was closed and then reopened, it will default to a board that was 
previously selected. You may need to explicitly select Intel Galileo Fab D.  

9. Select your serial port 

Select the serial device of your board from the Tools > Serial Port menu.  

Windows:  Use the COMx number assigned earlier. You can retrieve the port number 
by navigating to: Start > Control Panel > System and Security > System 
>Device Manager  Look under Ports (COM & LPT) to see which COMx is assigned 
to Gadget Serial  

Linux:  Use /dev/ttyAMC0  

Mac OS:  Use /dev/cu.usbmodemnnnnn  
 

10. Upload the program 

Click the Upload button in the IDE and wait a few seconds. If the upload is successful, 
the message Done uploading. will appear in the status bar.  

A few seconds after the upload finishes, you will see a green LED on the board start to 
blink. Congratulations! You've gotten your board up and running.  
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11. Booting your board from an SD card (mandatory for WiFi)  

Note: If you want to use WiFi, you must follow these steps. The WiFi driver is not present in 
the Linux image in SPI flash because it is too large. The Linux SD image also includes 
ALSA, V4L2, python, SSH, node.js, and openCV.  

To boot your board from an SD card, follow these steps. This also enables persistent 
rootfs and persistent /sketch folder.  

Required files are in the meta-clanton zip file (download link in Section 2).  
1. Copy all files/directories from the meta-clanton zip file to the SD card.  

You do not need to create a directory on the SD card. The zipfile contains all the 
necessary files and structure, make sure it is extracted at the top level of the SD 
card. See the screenshot below for a sample view.  

 
 

2. Insert the SD card, then power on the board.  

Note: The first time you boot the board may take several minutes. This is expected behavior 
due to the SSH component creating cryptographic keys on the first boot.  

 

12. Manually update your board firmware (optional) 

Note: This method has been replaced by functionality in the IDE. It is provided for reference 
only.  

You must update the firmware the first time you use the board to ensure the firmware 
on the board is in sync with the IDE.  

These steps assume you have a microSD card inserted into the slot on the board, 
which contains the release-specific sysimage_nnnn.cap file and the CapsuleApp.efi 
file. 

Caution: The CapsuleApp.efi and the *.cap file are a matched pair and must be used 
together. When a new *.cap file is released, you must use the corresponding 
CapsuleApp.efi to install it.  
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Perform the steps below: 
1. Download the SPI flash image capsule files as described in Section 2.  
2. Copy CapsuleApp.efi and sysimage_nnnnn.cap to a microSD card and insert it 

into the slot on the board . 
3. Connect the serial cable between the computer and the Galileo board. Set up a 

serial console session (for example, PuTTY) and connect to the Galileo board’s 
COM port at 115200 baud rate. 

4. Configure the serial console session to recognize special characters. For example, 
if you are using PuTTY, you must explicitly enable special characters. In the PuTTY 
Configuration options, go to the Terminal > Keyboard category and set the 
Function keys and Keypad option to SCO.  

5. Power on the board. A GNU GRUB boot loader menu is displayed (below).  
Exit GRUB by entering c and quit as shown below. 

 

Press c to get a command line.  

 

At the GRUB command line, type quit. 
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6. The serial console displays a boot device selection box (below).  
Select UEFI Internal Shell. 

 
You will see a display similar to this: 

 
 

7. You will see a print out, the top line of which looks like this: 
fs0  :HardDisk - Alias hd7b blk0 

This is your SD card. To mount it, type:  fs0: 
8. Verify you are using the correct version of CapsuleApp.efi by using the  -? or –h 

option. You must use version 1.1 or later.   
9. Enter the following command:  

CapsuleApp.efi sysimage_nnnnn.cap  

Note: You must enter the full filename of the sysimage_nnnnn.cap file.   
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You will see a display similar to this: 

 

The CapsuleApp will update your SPI flash image. This process takes about 2 
minutes. 

Warning: DO NOT remove power or try to exit during this process. Wait for the 
prompt to return, otherwise your board will become non-functional.  

10. When the update completes, reboot the board by removing and reconnecting the 
power cable. You will see a display similar to this: 
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