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1 About This Guide  
 
This guide helps you get started using the Intel® Visual Fortran Compiler 8.1 product. It 
describes Intel Visual Fortran installation and post-installation tasks, use of Intel Visual 
Fortran, and lists documentation and technical support resources. This guide assumes that 
you are familiar with the Fortran programming language, the Intel® processor 
architecture, and your Windows* operating system environment. 
 
The installation instructions in this guide apply to the Intel® Visual Fortran Compiler 
8.1, Standard Edition and the Intel® Visual Fortran Compiler 8.1, Professional Edition. 
With the Professional Edition, after you install the compiler, you can install the IMSL* 
libraries provided with the Professional Edition. 
 
It contains the following chapters: 
 
• Chapter 1, About This Guide 
 

The chapter you are reading describes the contents of this guide, related publications, 
and conventions used in this guide. 

 
• Chapter 2, Prerequisites for Installing Intel Visual Fortran 
 

This chapter describes some of the system requirements and software requirements 
for installing Intel Visual Fortran, the Intel® Debugger, and Intel® Array Visualizer. 
It describes installation options and provides information about specifying the license 
file. 
 

• Chapter 3, How to Install Intel Visual Fortran 
 

This chapter describes the step-by-step installation procedures for installing Intel 
Visual Fortran and Intel Array Visualizer. 

 
• Chapter 4, Post-Installation Tasks 
 

This chapter describes post-installation tasks required to use Intel Visual Fortran, 
including understanding the program folders, how to reinstall or remove Intel Visual 
Fortran or Intel Array Visualizer, restrictions related to using Compaq* Visual 
Fortran project files, and how to register and check for product updates. 
 

• Chapter 5, Using Intel Visual Fortran 
 

This chapter shows how to use Intel Visual Fortran, including the command-line 
environment, using the Microsoft* Visual Studio* .NET* development environment, 
using debuggers. It describes such product features as the Intel® Array Visualizer, 
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compatibility with Compaq* Visual Fortran, the Fortran 95 language, and library 
interface definitions provided by Intel Fortran. 
 

• Chapter 6, Documentation Road Map 
 
This chapter provides an overview of the online (on-disk) documentation for Intel 
Visual Fortran, Intel Array Visualizer, and the Compiler Performance Tutorial. 
 

• Chapter 7, Technical Support 
 
This chapter provides an overview of Intel Visual Fortran technical support and 
describes the use of the Intel® information reporter tool that you can use to provide 
system information when requested by the Intel technical support team. 
 

Related Publications 
 
The Intel Visual Fortran and Intel Array Visualizer documentation includes the 
following: 
 
• Intel® Visual Fortran Compiler for Windows* Systems User’s Guide, Volume I: 

Building Applications 
• Intel® Visual Fortran Compiler for Windows* Systems User’s Guide, Volume II: 

Optimizing Applications 
• Intel® Fortran Language Reference 
• Intel® Fortran Libraries Reference 
• Intel® Array Visualizer online documentation, Intel® Array Viewer online 

documentation 
• Enhancing Performance with Intel® Compilers (interactive training) 
• Using the Intel® License Manager for FLEXlm* 
• Release notes for Intel Visual Fortran 
• Release notes for Intel Array Visualizer 
 
For more information about Intel Visual Fortran and Intel Array Visualizer 
documentation, see Chapter 6.  
 
For software requirements and last-minute information about this release, please read the 
release notes. You can read the release notes before you install Intel Visual Fortran (see 
Reading the Release Notes and Documentation Before Installation in Chapter 2). 
 
For additional technical product information including white papers about Intel 
compilers, open the page associated with your product at: 
 
http://developer.intel.com/software/products 
 

 1-2

http://developer.intel.com/software/products


In addition to the documentation provided with Intel Visual Fortran, Intel provides 
architecture documentation, which you can view or download from the following Internet 
Web site: 
 
http://developer.intel.com/ 
 
For example, the following are some of the pages about the Intel architecture. 
 

For information 
about the … 

Click: 

Intel® Xeon™ 
processor  

http://developer.intel.com/design/Xeon/ 
 

Intel® Pentium® 4 
processor 

http://developer.intel.com/products/desktop/processors/Pentium4/ 
 

Intel® Itanium® 
processor 

http://developer.intel.com/design/itanium/itanium/ 
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2 Prerequisites for Installing Intel® Visual Fortran 
 
This chapter describes the steps you need to take to ensure that your installation of Intel® 
Visual Fortran will be successful. 
 
System and Software Requirements for Intel Visual Fortran 
 
Before you install Intel Visual Fortran and its related software, make sure that your 
system meets or exceeds the hardware requirements and has the required software 
installed. 
 
You can build applications for Intel® Itanium®-based systems running Windows* 
operating systems. To do this, you need to select and install the Intel Visual Fortran 
Itanium-based compiler during installation when using either an: 
 
• Itanium-based system running a Windows operating system. 
• IA-32 system running a Windows operating system. 
 
You can build applications for IA-32 systems running Windows operating systems only 
from an: 
 
• IA-32 system running a Windows operating system. 
 
If you have the necessary software installed, you can choose to install both compilers on 
the same IA-32 system, so you can build applications for both Itanium-based systems and 
IA-32 systems. For information on IA-32 systems with Intel® Extended Memory 64 
Technology (Intel® EM64T) see the Intel® Visual Fortran Compiler 8.1 Extended 
Memory 64 Technology Edition for Windows* Release Notes. 
 
The following table summarizes the type of processor systems and the methods you can 
use to build applications for IA-32 or Itanium-based systems running Windows operating 
systems. 
 

To build 
applications for: 

On this type of 
system: 

You can use any of the following methods: 

IA-32 systems IA-32 system  • The command line (including makefiles). 
• The Microsoft Visual Studio* .NET* build 

environment. 
Itanium-based 
systems  

IA-32 system • The command line (including makefiles). 

Itanium-based  
systems 

Itanium-based 
system 

• The command line (including makefiles). 
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Note: If you have installed Intel Fortran Compiler 7.1 and included integration 
with the Microsoft Visual Studio* .NET* environment during the installation, you 
must remove Visual Studio.NET integration with Intel Fortran Compiler 7.1 
before you install Intel Visual Fortran 8.1 on the same system (see Checking for 
and Removing Intel® Fortran 7.0 or 7.1 Integration with Microsoft Visual Studio 
.NET). 
 
Note: The Intel Visual Fortran Compiler 8.1 can coexist on the same system with 
the Compaq* Visual Fortran 6.x products. For more information, see Chapter 5. 
 

Processor, System, and Software Requirements to Build Applications 
 
Before you install Intel Visual Fortran on the appropriate system, please read the release 
notes to ensure that the system meets the requirements.  
 
The online release notes contain up-to-date information about processor, system, and 
software requirements, including: 
• processor requirements 
• RAM requirements 
• disk space requirements  
• virtual memory requirements 
• operating system requirements  
• development environment software requirements 
 
For more information about reading the release notes, see Reading the Release Notes and 
Documentation Before Installation. 
 
Checking Disk Space and Virtual Memory 
 
To check on the disk space available for a disk on your system: 
 

1. Click My Computer 
2. Right click the disk drive where you will install Intel Visual Fortran and select 

Properties from the pop-up menu 
3. View the disk space available 

 
To check on the virtual memory page file size on your system: 
 

1. Display the Control Panel (Start > Settings > Control panel) 
2. Click the System icon  
3. On Windows 2000 and XP systems: 

• Click the Advanced tab 
• In the Performance section, click the Settings button. 
• In the Performance Options dialog box, click the Performance Settings button 
• View the Virtual Memory size displayed 

4. On other Windows systems: 
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• Click the Performance tab 
• Click the Virtual Memory button 
• View the Virtual Memory size displayed (or whether Windows manages 

virtual memory size) 
 
System and Software Requirements for Intel® Array Visualizer  
 
Intel® Array Visualizer can be installed only on IA-32 systems that are running  
the Windows 2000 and Windows XP operating systems. In addition, to use Intel Array 
Visualizer or Intel® Array Viewer, you must have Microsoft Internet Explorer 6.0 or 
later installed. 
 
To view graphs, your graphics card and monitor need to support a sufficient number of 
colors, such as 16-bit or higher color. It is also recommended that your graphics card 
support OpenGL*. 
 
Software Requirements for the Intel® Debugger 
 
On IA-32 systems, the Intel® Debugger runs on the operating systems supported by Intel 
Visual Fortran installation (see the online release notes). On IA-32 systems, you can use 
the integrated Microsoft Visual Studio .NET debugger (see Using Debuggers). 
 
On Itanium-based systems, the Intel Debugger can be installed on the same operating 
systems supported by Intel Visual Fortran.  
 
Understanding Software Components and Your Installation Options 
 
During installation, you will be asked to respond to certain dialog boxes and make 
decisions related to installation.  
 
One decision includes where the installation files will be installed. For most of the 
installation files, the default base location is: 
 
     C:\Program Files\Intel\Fortran 
 
You can specify that Intel Visual Fortran be installed in a different directory on the same 
or a different disk. You can choose to install or not install certain software components, 
including the following: 
 

• Intel Visual Fortran IA-32 Compiler 
• Intel Visual Fortran Itanium-based Compiler either installed on an Itanium-based 

system (native compiler) or installed on an IA-32 system (cross compiler)  
• Intel Debugger (idb) 
• Intel Array Visualizer 
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To install the Intel Visual Fortran Itanium-based Compiler, you need to have installed the 
most recent Microsoft Platform SDK. 
 
The installation setup program lets you choose whether to select a Typical or Custom 
installation type. Both installation types let you choose whether an entire component will 
be installed on a local disk or not installed. The Typical installation type is sufficient for 
most users and installs all components, and installs them in the same disk/directory 
location.  The Custom installation type lets more advanced users choose to: 
 

• Install or not install the entire component on local disk. 
• Install some of the subcomponents of this component on local disk (if it has 

subcomponents). 
• Specify the disk/directory location for the files to be installed. 
• Choose whether Intel Visual Fortran compiler environment variable definitions 

will be set system-wide. 
 
Activating the License File 

The Intel Visual Fortran Compiler uses Macrovision* FLEXlm* electronic licensing 
technology. Unless your Intel Visual Fortran license is already active, you need to 
activate your license before you can install Intel Visual Fortran. Also, the license must 
remain in place to use Intel Visual Fortran or Intel Array Visualizer. 

The default directory that contains license files for Intel Visual Fortran: 

• On IA-32 systems: 

C:\Program Files\Common Files\Intel\Licenses\ 

• On Itanium-based systems: 

C:\Program Files (x86)\Common Files\Intel\Licenses\ 

If this license directory does not exist on your system when you install Intel Visual 
Fortran, the license directory will be created and you will be prompted to specify the 
license file. You can also copy the license file to the license directory (shown above) 
before starting installation. License files have a file extension (suffix) of .lic.  

The Intel Visual Fortran license can coexist with some previous versions of the Intel 
Fortran license. Intel Visual Fortran (and Intel Fortran) licensing technology changed 
with Version 6, so unless your license subscription has expired, Version 7.x and 8.0 
licenses are valid for Intel Visual Fortran 8.1. 

If you are using counted Intel Visual Fortran licenses (floating or node-locked) associated 
with Macrovision FLEXlm electronic licensing technology, and your license file and 
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license server are not already setup and running, you need to first install the Intel license 
manager software before you can configure your license server: 

1. Open the Intel® Software Development Tools program folder (Start > 
Programs > Intel® Software Development Tools) 

2. If not done previously, click: Intel® FLEXlm* license manager > Install. 
Accept the license agreement, specify the path and name of the license file 
for your counted license (or choose to specify the file later), and follow other 
displayed instructions needed to install the Intel license manager software. 

3. Once the license manager is installed, click: Intel® FLEXlm* license 
manager > Configure Intel® FLEXlm* license server. If you have not 
done so during installation of the Intel license manager, specify the counted 
license file. You can then start the license server (click the Start Server button 
or from the Services control applet). For more information, see the online 
guide Using the Intel® License Manager for FLEXlm*. 

 
Removing the Intel Visual Fortran Compiler does not delete the corresponding license or 
any other Intel license file.  
 
Removing Previous Versions of Intel® Visual Fortran 8.0 or 8.1 

If you are using Intel Visual Fortran Compiler 8.0 or an earlier version of Intel Visual 
Fortran Compiler 8.1, you must uninstall it prior to installing this product by using the 
Control Panel, Add/Remove Programs item (see Changing Installation Options, 
Reinstalling, or Removing Intel Visual Fortran). 

Checking for and Removing Intel® Fortran 7.0 or 7.1 Integration with 
Microsoft Visual Studio .NET 

If you have installed Intel Fortran Compiler 7.1 or 7.0 with integration with the Microsoft 
Visual Studio .NET environment, you must remove the Intel Fortran 7.1 or 7.0 
integration with the Microsoft Visual Studio.NET before you install Intel Visual Fortran 
8.1 on the same system. However, if you want to install Intel Visual Fortran 8.1 with no 
integration with Microsoft Visual Studio .NET and leave the Intel Fortran 7.1 or 7.0 
integration with Microsoft Visual Studio .NET unchanged, you must perform a Custom 
installation of Intel Visual Fortran 8.1 and deselect integration with both versions of 
Microsoft Visual C++ .NET. 

If your Intel Fortran 7.x installation was integrated with Microsoft Visual Studio 98 or 
Visual C++ 6 and not with the same version of Microsoft Visual Studio .NET, you do not 
need to remove these components of Intel Fortran 7.1 or 7.0 before installing Intel Visual 
Fortran 8.1 on the same system.  

To check and remove the Intel Fortran 7.1 or 7.0 integration with the Microsoft Visual 
Studio.NET environment you need to modify the installation of Intel Fortran 7.x: 
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• Start the Control Panel and select Add/Remove Programs item 

• Select Intel® Fortran Compiler 7.1 or Intel® Fortran 
Compiler 7.0. 

• Click the Change button 

• Click the Next> button 

• Click (select) Modify 

• Under Intel Fortran Compiler for 32-bit Applications, click 
the plus sign (+) to the left of Microsoft Visual Studio Integration.   

• If selected (a disk icon means it is selected; an X means it is deselected), you 
may need to deselect For Microsoft Visual C++ .NET 2002 and 
deselect For Microsoft Visual C++ .NET 2003.  
 
With Intel Fortran 7.0, you must remove integration with both Visual C++ 
.NET 2002 and Visual C++ .NET 2003.  
 
With Intel Fortran 7.1 (please see the release notes for more information), you 
can have Intel 7.1 integrate with one version and Intel Visual Fortran integrate 
with the other version of Visual C++  .NET. For example, Intel Fortran 7.1 
can integrate with Visual C++ .NET 2002, and Intel Visual Fortran can be 
integrated with Visual C++ .NET 2003.  

• Click the Next> button  

• Reply to other dialog boxes, and click the Install button to begin the 
installation 

Please see the release notes for the latest information. 
 

Reading the Release Notes and Documentation Before Installation  
 
When installing Intel Visual Fortran from CD-ROM media, you can read the release 
notes before installation. Use a Web browser to open the frelnotes.htm file located in 
the CD-ROM root directory (in the File menu, click Open, click the Browse or Choose 
File button). 
 
When installing Intel Visual Fortran from a Web download package, the downloaded file 
is unpacked into an intermediate directory that you specify. You can read the release 
notes from this intermediate directory by using a Web browser to open the 
frelnotes.htm file (in the File menu, click Open, click the Browse or Choose File 
button). 
 
Whether you are using the CD-ROM media or the unpacked intermediate directory of the 
Web download, the html directory contains this guide and other Intel Visual Fortran 
documentation (see Chapter 6). 
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3 How to Install Intel® Visual Fortran and its Components 
 
This chapter provides detailed installation instructions for installing the Intel® Visual Fortran 
compiler and, optionally, its major components: the Intel® Array Visualizer (IA-32 systems 
only) and the Intel® Debugger (idb). 
 
Before you use the instructions in this chapter, make sure that you have completed the steps 
described in the previous chapter. For example, if you have Intel Visual Fortran compiler 8.0 or 
an earlier version of Intel Visual Fortran compiler 8.1 installed, you need to remove it before 
installing Intel Visual Fortran compiler 8.1 (see Removing Previous Versions of Intel® Visual 
Fortran 8.0 or 8.1). 
 

Note:  On Microsoft* Windows* 2000 and Windows XP systems, you must use an account 
with administrative privilege to install or remove the Intel Visual Fortran Compiler and its 
components. 

 
If you are installing Intel Visual Fortran from CD-ROM, please skip to the section Starting the 
Installation from CD-ROM or Disk. 
 
Web Installation: Unpacking the Download File 
 
With the Web download package, the downloaded file is unpacked into an intermediate directory 
that you specify. To unpack the downloaded file: 
 

1. Use Windows Explorer or My Computer to locate the directory containing the 
downloaded file. 

2. Double-click the downloaded file to display a screen resembling the following: 
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3. Specify the location of an intermediate directory where the downloaded files will be 
unpacked or click the Change… button to browse your system and select a disk and 
directory location.  If you are not sure whether there is enough disk space on the disk 
where Intel Visual Fortran will be installed, choose a different disk. 
 
• You should remember this intermediate directory for future reference, for example, to 

free up disk space after installation. You should retain either the downloaded file or 
the contents of this intermediate directory to reinstall this version of Intel Visual 
Fortran. 
 

4. Click the Next> button to begin copying the contents of the downloaded file into the 
intermediate directory. A dialog box appears showing the progress of the extracted files. 
When complete, your Web browser appears, initiating the installation of Intel Visual 
Fortran. 

 
You do not need to keep both the downloaded file and the contents of the intermediate directory. 
You need only one of these to reinstall this version of Intel Visual Fortran (see Removing the 
Intermediate Download Directory in Chapter 4). 
 
Starting the Installation from CD-ROM or Disk  
 
After you unpack the downloaded file or insert the Intel Visual Fortran CD-ROM, a Web page 
appears in your Web browser displaying the Intel® Visual Fortran name and version number, 
such as Intel Visual Fortran 8.1 for Windows*. 
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If you are installing Intel Visual Fortran from CD-ROM, insert the Intel Visual Fortran CD-
ROM into a CD-ROM drive. Your Web browser should automatically appear displaying the Intel 
Visual Fortran installation page; if it does not display, double-click the file name autorun.exe in 
the: 
 
• Root directory of the CD-ROM  
• Top-level (intermediate) directory that you selected when you unpacked a Web download of 

Intel Visual Fortran 
 
This introductory Web page can be activated whenever needed, not only to install or reinstall 
Intel Visual Fortran, but also for easy access to the helpful Web links displayed in the left 
margin. For example, links in the left margin allow you to: 
 

• Register for technical support 
• Display a page containing relevant Web links 
• Access the Intel® Premier Support Web pages 
• Display this document  

 
If you select one of the links in the left margin, click the Back button on your browser or click 
the link CD Home link in the left margin to return to the initial page. 
 

Note: Before you start the installation, make sure that you have activated the appropriate 
license file (see Activating the License File in Chapter 2). 

 
To start the installation of Intel Visual Fortran, locate and click the Install Compiler link, which 
is under the Installation heading on the left side of the screen. Follow the instruction on the 
screen. 
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Installing Intel Visual Fortran 8.1 
 
After loading the necessary installation software, the setup procedure checks for a valid license. 
If a valid license file is not found, the following screen appears. 
 

 
 
Before installation can occur, you need to save a valid license file to your disk. To do this, you 
need to: 

• register your product to obtain a serial number (See Intel® Visual Fortran Technical 
Support in Chapter 7, or view the online release notes.) 

• locate the license file sent to your specified email address 
• save the license file to a disk with a file extension (suffix) of .lic. 

 
After you have saved the license file, either type the path and file name or click the Browse… 
button to specify the location and file name of the license file. The license file will be copied to 
the necessary location.  For the location of the license file and related information, see Activating 
the License File.  
 
After you specify a valid license file, click the OK button. The following Welcome dialog box 
appears: 
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Click the Next> button to continue. To exit from the Intel Visual Fortran installation setup 
process at any time, click the Cancel button in the lower right of a dialog box. 
 
If you previously installed Intel Visual Fortran, a dialog box will appear asking you whether you 
want to repair, modify, or remove Intel Visual Fortran.  
 

Note: If you want to install a newer version, you must choose to remove the previous 
version first. 

 
To modify or repair the same version of Intel Visual Fortran, you can select: 
 

• Modify to change whether or not certain components are installed on disk (or where they 
are installed). 

• Repair if you are having problems with the current installation but do not want to change 
which components are installed on disk. 

 
If this is a new installation of Intel Visual Fortran, the License Agreement dialog box appears: 
 

1. Read the License Agreement. Use the scroll bar or Page Down key to display the 
entire text. 

2. If you agree with the terms of the License Agreement, click the Yes button to 
continue. Alternatively, you can either click the <Back button to display the previous 
dialog box, or click the No button if you want to exit the installation of Intel Visual 
Fortran. 

 3-5



The Customer Information dialog box appears: 
 

1. Enter your name and (if applicable) your company’s name.  
2. You can also specify whether this installation of Intel Visual Fortran can be used only 

by the account you are using to perform the installation or by other accounts using 
this computer system. 

3. Click the Next> button to continue.  Alternatively, you can click the <Back button to 
display the previous (License Agreement) dialog box. 

 

Setup Type Dialog: Choose a Typical or Custom Installation 
 
After the Customer Information dialog box, the Setup Type dialog box appears: 
 

 
 
The Setup Type dialog box asks whether you want to: 
• perform either a Typical or a Custom installation. 
• accept the default destination directory (folder) or specify a different directory where files 

will be installed. 
 
Select the Typical installation type if you want all possible components installed on your local 
hard disk, including Intel® Array Visualizer (IA-32 systems only) and the Intel® Debugger.  
The Typical installation type requires that all components are installed on the same 
disk/directory location.   
 
Unless you have disk space limitations, most users should select the Typical installation type. 
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Select a Custom installation if you want control over how the components are installed on your 
local disk and if you want to select or deselect components. Using a Custom installation lets you 
choose to: 
 

• install the entire component on local disk 
• install some of the subcomponents of this component on local disk (if it has 

subcomponents) 
• not install the entire component on the local disk 
• specify the disk/directory location for each component 
• choose whether Intel Visual Fortran compiler environment variable definitions will be 

set system-wide 
 

After you click on the line for either the Typical or Custom installation type, you need to decide 
where the Intel Visual Fortran and related files will be installed. 
 
The default base location that you can specify is: C:\Program Files\Intel\Fortran. If 
you accept this default base location, components are installed in directories below that location; 
for example, Intel Visual Fortran files are installed in …\Compiler80: 
 

Component Default Installation Location  
Intel® Visual Fortran C:\Program Files\Intel\Fortran\Compiler80 

Intel® Array Visualizer C:\Program Files\Intel\Fortran\Array Visualizer 

Intel® Debugger: C:\Program Files\Intel\Fortran\IDB80 
 
To specify a different base directory location, click the Browse… button, which displays the 
Choose Folder dialog box. You can use the Choose Folder to specify a different disk device 
(scroll to the top of the displayed directory hierarchy) or specify the desired directory by 
selecting it or typing in its name. Click the OK button when you have specified the desired disk 
and directory location. 
 
After you choose either a Typical or Custom installation and accept or specify a destination 
directory, click the Next> button in reply to the Setup Type dialog box. The dialog box that 
appears next depends upon whether you selected a Typical or a Custom installation. 
 
If you selected a Custom installation, skip to the section Performing a Custom Installation. 
 

Performing a Typical Installation 
 
If you selected a Typical installation, the system checks to determine whether: 
 

• You have the software needed to install all components. If prerequisite software needed 
for a component is not installed, a Missing Prerequisite dialog box appears, displaying 
the Intel Visual Fortran component and the name of the missing prerequisite software. 
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For example, if you do not have the Microsoft* Platform SDK installed on your system, 
you should not install the Intel Visual Fortran Compiler for Itanium®-based Systems. 

 
• You have more than one Microsoft Visual Studio* .NET* development environment 

installed. In this case, the Multiple Development Environment dialog box appears, asking 
which of these Microsoft visual development environments will be used for Intel Visual 
Fortran command-line use. Intel Visual Fortran command-line use is limited to only one 
visual development environment, which you must select. 

 
You can use Intel Visual Fortran compiler within any of the supported Microsoft visual 
development environments (Microsoft Visual Studio .NET or Microsoft Visual Studio 
.NET 2003). 
 

• If you have installed Intel Fortran Compiler 7.1 or 7.0 with integration with the Microsoft 
Visual Studio .NET environment, you must remove Intel Fortran Compiler 7.x’s 
integration with the Microsoft Visual Studio .NET before you install Intel Visual Fortran 
8.1 on the same system, as described in Checking for and Removing Intel® Fortran 7.0 or 
7.1 Integration with Microsoft Visual Studio .NET. 

 
The Environment Variables dialog appears, allowing you to set system-wide environment 
variables for command-line execution: 
 

 
 
This dialog box lets you choose whether the Intel Visual Fortran compiler environment variable 
definitions for PATH, LIB, and INCLUDE should be set system-wide. If you do not set the 
environment variables system-wide, when you use the command line you can use the supplied 
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Intel Visual Fortran command-line environment (Build Environment for xxx 
applications item in the Intel Visual Fortran program folder) or apply the appropriate 
ifortvars.bat file (see Using the Command Line in Chapter 5). You can also set the 
environment variables within the Microsoft visual development environment. 
 
Also, to run applications that have been linked against the Intel Visual Fortran Dynamic Link 
Libraries (DLLs), you will need the PATH environment variable to be defined either system-
wide or defined for each environment (such as ifortvars.bat for a command line window) in 
which it is run. 
 
If you will do any of the following, you do not need system-wide environment variables set: 

• If you will not use the command-line environment. 
• If you will use the supplied command-line environment provided by the Intel Visual 

Fortran program folder. 
• If you will use your own command-line environment and will execute the 

ifortvars.bat file to set environment variables. 
 
You do need to set system-wide environment variables if your applications are linked against 
Intel Visual Fortran DLLs and you will not execute the ifortvars.bat file (or otherwise set 
the PATH environment variable) before executing those applications. 
 
After deciding whether to update the environment variables system-wide (check box enabled) or 
not update them (check box clear), click the Next> button to proceed to the Start Copying Files 
dialog box. In reply to the Start Copying Files dialog box, click the: 
 

• Next> button to begin installation. 
• <Back button to return to the previous dialog box (to select a Custom installation, click 

the <Back button several times to return to the Setup Type dialog box). 
• Cancel button to exit the installation setup process. 

 
Once you begin installation, files are copied to the target directories (Setup Status dialog box 
appears). When complete, the InstallShield* Wizard Completed dialog box appears. Click the 
Finish button to complete the installation of Intel Visual Fortran. 
 
If needed, you will be prompted to reboot your system. 
 
You can now become familiar with the contents of the Intel Visual Fortran and related program 
folders, as well as understand applicable post-installation tasks. Skip to Chapter 4 Post-
Installation Tasks. 
 

Performing a Custom Installation 
 
After you select a Custom installation, the Select Features dialog box similar to the following 
one (shown for an IA-32 system where the Platform SDK was previously installed) appears: 
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The Select Features dialog box lets you choose for each component whether: 
 

• The entire component will be installed on a local disk. 
• The entire component will not be installed. 
• Some of the subcomponents of this component will be installed on a local disk (if it has 

subcomponents). 
 
In the sample dialog box shown above: 
 

• The prerequisite Microsoft Platform SDK was installed, so the component Intel Visual 
Fortran Compiler for Itanium-based Systems is selected. 

• The default for the Intel Visual Fortran Compiler for 32-bit applications is to install all 
components on the local disk, so the component is selected. 

 
To change whether the component is installed on the local disk or not installed, click the check 
box to the left of the component name. All components are installed in the destination disk and 
folder directory specified in the Setup Type dialog box (click the <Back button to view the Setup 
Type dialog box). 
 
After you have specified whether the components and subcomponents will be installed on the 
local disk, click the Next> button. Alternatively, you can press the <Back button to return to the 
Setup Type dialog box or press Cancel to exit the installation setup procedure. 
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After you click the Next> button, the system checks to determine whether: 
 

• You have the software needed to install all components. If prerequisite software needed 
for a component is not installed, a Missing Prerequisite dialog box appears, displaying 
the Intel Visual Fortran component and the name of the missing prerequisite software. 
For example, if you do not have the Microsoft* Platform SDK installed on your system, 
you should not install the Intel Visual Fortran Compiler for Itanium®-based Systems. 

 
• You have more than one Microsoft Visual Studio .NET development environment 

installed. In this case, the Multiple Development Environment dialog box appears, asking 
which of these Microsoft visual development environments will be used for Intel Visual 
Fortran command-line use. Intel Visual Fortran command-line use is limited to only one 
visual development environment, which you must select. 

 
You can use the Intel Visual Fortran compiler within any of the supported Microsoft 
visual development environments (Microsoft C++*.NET* or Microsoft Visual 
C++*.NET 2003).  
 

The Environment Variables dialog appears, allowing you to set system-wide environment 
variables for command-line execution: 
 

 
 
This dialog box lets you choose whether the Intel Visual Fortran compiler environment variable 
definitions for PATH, LIB, and INCLUDE should be set system-wide. If you do not set the 
environment variables system-wide, when you use the command line you can use the supplied 
Intel Visual Fortran command-line environment (Build Environment for xxx 
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applications item in the Intel Visual Fortran program folder) or apply the appropriate 
ifortvars.bat file (see Using the Command Line in Chapter 5). You can also set the 
environment variables within the Microsoft visual development environment. 
 
Also, to run applications that have been linked against the Intel Visual Fortran Dynamic Link 
Libraries (DLLs), you will need the PATH environment variable to be defined either system-
wide or defined for each environment (such as ifortvars.bat for a command line window) in 
which it is run. 
 
If you will do any of the following, you do not need system-wide environment variables set: 

• If you will not use the command-line environment. 
• If you will use the supplied command-line environment provided by the Intel Visual 

Fortran program folder. 
• If you will use your own command-line environment and will execute the 

ifortvars.bat file to set environment variables. 
 
You do need to set system-wide environment variables if your applications are linked against 
Intel Visual Fortran DLLs and you will not execute the ifortvars.bat file (or otherwise set 
the PATH environment variable) before executing those applications. 
 
After deciding whether to update the environment variables system-wide (check box enabled) or 
not update them (check box clear), click the Next> button to proceed to the Start Copying Files 
dialog box. In reply to the Start Copying Files dialog box, click the: 
 

• Next> button to begin installation. 
• <Back button to return to the previous dialog box (to select a Typical installation, click 

the <Back button several times to return to the Setup Type dialog box). 
• Cancel button to exit the installation setup process. 

 
Once you begin installation, files are copied to the target directories (Setup Status dialog box 
appears). When complete, the InstallShield Wizard Completed dialog box appears. Click the 
Finish button to complete the installation of Intel Visual Fortran. 
 
If needed, you will be prompted to reboot your system. 
 
You can now become familiar with the contents of the Intel Visual Fortran and related program 
folders, as well as understand applicable post-installation tasks. Skip to Chapter 4 Post-
Installation Tasks. 
 
Installing the Intel® Visual Fortran Compiler 8.1, Professional Edition, for 
Windows* 
 
The steps and procedures included in the previous sections of this chapter generally apply to 
installing the Intel® Visual Fortran Compiler 8.1, Professional Edition, for Windows* product.  
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Follow the same general steps to install the Professional Edition from either CD-ROM or a 
downloaded file as you would to install the Standard Edition. 
 
The IMSL* Libraries are installed separately from the compiler, and the IMSL* Libraries must 
be installed after installing the Professional Edition of Intel Visual Fortran compiler. 
 
For information on installing the IMSL* Libraries refer to the installation instructions displayed 
when you start the Intel® Visual Fortran Compiler 8.1, Professional Edition, for Windows* 
installation from CD-ROM or disk (see Starting the Installation from CD-ROM or Disk). 
 
See the Using the IMSL* Libraries section for information on using the IMSL* Libraries. 
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4 Post-Installation Tasks  
 
This chapter discusses certain tasks you need to perform after installation. 
 
Understanding the Intel® Visual Fortran and Intel® Debugger 
Program Folders 
 
The Intel® Visual Fortran program folder is displayed when you click: 
 
Start > Programs > Intel® Software Development Tools > Intel® Fortran Compiler 
8.1 
 
The contents of the Intel Visual Fortran program folder depends upon the components 
selected during installation and might include: 
 

Program Folder Item Description 
Intel® Debugger 8.1 Program folder for the Intel Debugger, such as 

documentation, the command-line interface, the Intel 
Debugger GUI, and release notes. 

Build Environment for 
Fortran IA-32 applications 
(if installed) 

Displays a command-line window for developing Intel 
Visual Fortran applications for IA-32 systems from the 
command line. 

Build Environment for 
Fortran Itanium®-based 
applications (if installed) 

Displays a command-line window for developing Intel 
Visual Fortran applications for Itanium-based systems 
from the command line. 

Compiler Performance 
Tutorial 

Displays the Intel® Compiler performance tutorial in a 
Web browser. 

Documentation Index Provides an HTML file with links to the Intel Visual 
Fortran and related documentation (see Chapter 6) notes 
(displayed in a Web browser). 

Intel® information reporter Displays the Intel information reporter tool, which can 
be used to gather information about your system (see 
Chapter 7, Using the Intel information reporter tool). 

Release Notes Displays the Intel Visual Fortran release notes in a Web 
browser. 

 
In addition to the Intel® Visual Fortran and Intel Debugger program folders, other 
program folders include the Intel® License Manager for FLEXlm* program folder, the 
Registration and Support program folder, and the Intel® Array Visualizer program folder. 
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Copy Files Needed to Run Itanium-based Applications Created on an 
IA-32 System 
 
If you are developing IA-32 applications only or if you installed the Itanium-based Intel 
Visual Fortran compiler on your Itanium-based system and intend to use the Itanium-
based system to develop applications, skip this step. 
 
If you did not install the Itanium-based Visual Fortran compiler on your Itanium-based 
system and need to use an IA-32 system with the Intel Visual Fortran Itanium-based 
compiler to produce Itanium-based applications, you will need to copy specific, required 
files (.dll, .ocx, .lib, .exe, and .obj) for Itanium-based applications from your IA-32 
development system to the Itanium-based system. The required files provide the 
minimum environment needed to run Intel Visual Fortran Itanium-based applications on 
Itanium systems.  
 
See the Fredist.txt file, which is located in the ...\Compiler80\docs directory of the 
location specified during the installation, for a complete list of the required files. Search 
your IA-32 development system for the files listed in the Fredist.txt file, and copy the 
files in a directory structure on the Itanium-based system that mirrors the directory 
structures found on your IA-32 development system. You might need to create the 
necessary directory structure. 

Note: The DLLs in the Platform SDK directory "Microsoft Platform 
SDK\redist\PreRelease\win64" may also be required at runtime and 
should be copied into the same directory as the executable on the Itanium-based 
system, so they take precedence over any versions distributed with the operating 
system. Some of these DLL files are not distributed with the operating system and 
are only available from the Platform SDK. 

Changing Installation Options, Reinstalling, or Removing Intel Visual 
Fortran  
 
To remove Intel Visual Fortran, use the Control Panel: 

1. Display the Control panel (Start > Settings > Control panel). 
2. Double-click Add/Remove Programs. 
3. Scroll to and click Intel Visual Fortran Compiler 8.1. 
4. Click the Remove button. 
5. Verify that you want to remove Intel Visual Fortran and follow the displayed 

instructions. 
6. Also see the section Checking for and Removing Old Environment Variable 

Definitions later in this chapter. 
 
To modify installation options or to reinstall Intel Visual Fortran, obtain the Program 
Maintenance dialog box by doing the following: 

1. Display the Control panel (Start > Settings > Control panel). 
2. Select Add/Remove Programs. 
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3. Scroll to and click Intel Visual Fortran Compiler 8.1. 
4. Click the Change button. 

 
The Welcome to the InstallShield* Wizard for Intel Visual Fortran 8.1 dialog box 
appears. Click the Next> button to display the following dialog box: 
 

 
 
Select one of the following: 
 

• Modify: To change the components selected in the previous installation of the 
same version, select Modify. This displays the Custom Setup installation dialog 
box described in Chapter 3, Performing a Custom Installation. 

 
• Repair: To repair the existing installation without changing installation options of 

the same version, select Repair. The Setup Status dialog box appears. Click the 
Install button to reinstall the same components previously installed. 

 
• Remove: To remove Intel Visual Fortran and the Intel Debugger (for example, 

before installing a newer version), select Remove. The Remove All Components 
dialog box appears. Click the Remove button to remove Intel Visual Fortran and 
the Intel Debugger. The removal setup program will not remove your license files.  
You can manually remove the license files if needed.  
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Understanding the Intel® Array Visualizer Program Folder 
 
To display the contents of the Intel® Array Visualizer program folder, click: 
 
Start > Programs > Intel® Software Development Tools > Intel® Fortran Compiler  
8.1 > Intel® Array Visualizer 
 
The contents of the Intel Array Visualizer program folder include: 
 

Program Folder Item Description 
Array Viewer Displays the interactive Intel® Array Viewer, that lets you 

display previously saved data files (see Using the Intel Array 
Visualizer in Chapter 5). 

Documentation Displays an HTML page that lets you select the Intel Array 
Visualizer online documentation (see Chapter 6). 

Release Notes Displays an HTML page that contains the Intel Array 
Visualizer release notes. 

 
Note: Certain tasks must be performed before you can develop applications that 
use Intel Array Visualizer, as described in the Intel Array Visualizer online 
documentation or release notes. These tasks include adding appropriate directories 
to the PATH, LIB, and INCLUDE environment variables. 

 
Removing the Intermediate Download Directory 
 
If you used the Web download package, you needed to unpack it into an intermediate 
directory (see Chapter 3, Web Installation: Unpacking the Download File).  You can keep 
the contents of the intermediate directory or the downloaded package, but you do not 
need to keep both. In most cases, you can delete the contents of the intermediate 
directory. One exception is if you might change your options chosen during installation.  
 
Registering Your Purchase and Obtaining Product Updates 
 
If you purchased an Intel Visual Fortran CD-ROM package, you need to register your 
purchase and obtain and activate a new license. This enables you to receive technical 
support (see Chapter 7), which includes service updates. 
 
If you purchased an Intel Visual Fortran Web download package, you have already 
registered your Intel Visual Fortran purchase and do not need to obtain and activate a 
new license. You also automatically are registered to receive technical support (see 
Chapter 7). 
 
To determine whether any product updates are available, log in to your Intel® Premier 
technical support account (see Chapter 7). 
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Copying Compaq* Visual Fortran Project Files 
 
Before you use Intel Visual Fortran in the Microsoft Visual Studio* .NET* development 
environment, consider making back up copies of any Compaq* Visual Fortran 6 project 
directories. If you open project workspaces (such as .DSW files) for applications created 
with Compaq Visual Fortran 6 within the Microsoft Visual Studio .NET development 
environment, you will be asked whether you want to convert the project workspace into 
the Microsoft Visual C++ .NET format, which allows use with Intel Visual Fortran. 
Compaq Visual Fortran cannot read project workspace files that have been converted into 
the Microsoft Visual C++ .NET format. For more information, see the Intel® Visual 
Fortran Compiler for Windows* Systems User’s Guide. 
 
Redistributing Intel Visual Fortran and Intel Array Visualizer Files  
 
For information on redistributing your applications, see the Fredist.txt file, which is 
located in the ...\Compiler80\docs directory of the location specified during the 
installation. 
 
Increasing the Stack Size for Programs That Use Large Data Arrays  

Certain programs use large amounts of data. In particular, with those programs 
that use large allocatable arrays (dynamically allocated at run time) or use 
OpenMP* or related parallel processing, certain tasks must be performed to 
provide enough stack space for the program to run.  

Many kinds of variables and expressions can be allocated on the stack. If you are 
using array intrinsics or expressions, these can use large amounts of stack-
allocated temporary storage (temporaries), even if the original variable is static or 
dynamically allocated.  

The default stack size is about 1 MB. You can increase this by specifying the 
linker option /stack:nnnnn, where n is the number of bytes (in decimal) you want 
for the stack. This linker option can be specified when you link the executable, 
either on the command line by specifying the /stack:nnnnn linker option, or in the 
Visual Studio .NET environment by using the Linker properties, System category, 
Stack Reserve Size. 

To change the stack size of an already-linked executable, use the EDITBIN 
command, /stack:nnnnn option.  

Checking for and Removing Old Environment Variable Definitions 

Intel Visual Fortran modifies certain system-wide environment variables. You 
may need to remove the system-wide environment variables after you remove 
Intel Visual Fortran.   
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On Windows 2000 or Windows XP systems:  

1. Log into an account with Administrator privilege. 
2. Open the Control panel (Start > Settings> Control panel).  
3. Click the System icon. 
4. Click the Advanced tab, and then click the Environment Variables button.  
5. View the displayed environment variables.  
6. Make the necessary changes. 
7. To have the environment variable changes take effect immediately, click 

Apply.  
8. Click OK (to allow changes to be made) or Cancel (to not allow changes 

to be made. 

For example, in the System Variables tab, check the definitions of the PATH 
variable, which is used by Intel Visual Fortran and other products: 

• Double-click the PATH variable.  
• Near the bottom of the window, the variable PATH and its full 

definition appear.  
• Check the device and directory definitions of the PATH variable. If an 

older directory path exists, remove it. Directory path names are 
delimited by semicolons (;) and the last path name might contain 
%SystemRoot%.  

• Check the INCLUDE and LIB variables (used by Intel Visual Fortran 
and other program development products). 

• Check for the environment variable INTEL_LICENSE_FILE. If no 
other Intel software products are installed, this variable does not need 
to be defined. 
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5 Using Intel® Visual Fortran 
 
Overview  
 
On IA-32 systems, you can use Intel® Visual Fortran from the command line or from the 
Microsoft Visual Studio* .NET* development environment.  
 
On Itanium®-based systems, use the command line. 
 
Using the Command Line 
 
To create applications from the command line for IA-32 systems: 
 

• Use the Intel Visual Fortran command prompt, which has the appropriate 
environment variables already set for the command-line environment. In the Intel 
Visual Fortran program folder, select: 

                  Build Environment for Fortran IA-32 applications  
• Use the ifort command, either directly on a command line or in a makefile, to 

invoke the Intel Visual Fortran compiler to create 32-bit applications for IA-32 
systems.  

• Refer to the Intel® Visual Fortran Compiler User’s Guide for information on 
compiler options, customizing the compilation environment, using the nmake 
command to process makefiles, using optimizations for optimal run-time 
performance, and other compiler features.  

• If multiple versions of the Microsoft visual development environment were 
available when Intel Visual Fortran was installed, the user specified which 
environment would be used for Intel Visual Fortran compiler command-line use, 
in reply to the Multiple Development Environments dialog box (see Setup Type 
Dialog: Choose a Typical or Custom Installation). Intel Visual Fortran command-
line use is limited to only one of these visual development environments. 

 
To create applications from the command line for Itanium-based systems: 
 

• Use the Intel Visual Fortran command prompt, which has the appropriate 
environment variables already set for the command-line environment. In the Intel 
Visual Fortran program folder, select: 

                  Build Environment for Fortran Itanium®-based 
        Applications  

• Use the ifort command, either directly on a command line or in a makefile, to 
invoke the Intel Visual Fortran compiler to create applications for Itanium-based 
systems.  

• Refer to the Intel® Visual Fortran Compiler for Windows* Systems User’s Guide 
for information on compiler options, customizing the compilation environment, 
using optimizations for optimal run-time performance, and other compiler 
features.  
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If you selected the installation option to be able to create applications for Itanium-based 
systems on an IA-32 system, see Copy Files Needed to Run Itanium-based Applications 
Created on an IA-32 System before using the ifort command. 
For example, assume you have used a text editor (such as Notepad) to create a small 
program that displays the text Hello World! on the screen, such as the following: 
 
 PROGRAM HELLO 

 INTEGER I 
 DO I=1,3 
    WRITE (*,*) 'Hello World!' 
 END DO 

 END PROGRAM 
 
To compile and link the source file hello.f90 for debugging on an Itanium-based 
system, type: 
 
     prompt> ifort /Zi /Od hello.f90 
 
This creates the file hello.exe with symbol table debug information as well as 
hello.obj. If you are using an IA-32 system to create Itanium-based applications, copy the 
file hello.exe to the Itanium-based system before running the file. To run this file, type 
hello.exe: 
 
     prompt> hello.exe 
  Hello World! 
  Hello World! 
  Hello World! 
 
To compile a source file for higher optimization, omit the /Zi and /Od options and use 
the appropriate optimization options. For example, to compile calculate.f90 with 
highest optimization for an Itanium® 2 processor system, type: 
 
     prompt> ifort /O3 /G2 calculate.f90 
 
If your application contains newly created or ported source code, you can request source 
(compile-time) diagnostic warning messages by specifying the /warn option. For 
example, to compile and link the source file hello.f90 for debugging with all 
possible diagnostic message checking, type: 
 
     prompt> ifort /Zi /Od /warn:all hello.f90 
 
Refer to the Intel® Visual Fortran Option Quick Reference Guide for a summary of 
compiler options, including a list of new options and an alphabetic list of options. Refer 
to the Intel® Visual Fortran Compiler for Windows* Systems User’s Guide for detailed 
information on compiler options, customizing the compilation environment, using the 
nmake command to process makefiles, using optimizations for optimal run-time 
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performance, and other compiler features. For more information on Intel Visual Fortran 
documentation, see Chapter 6. 
 
The Intel Fortran Compiler 8.1 can coexist on the same system with the Compaq* Visual 
Fortran 6.x product. If you use the command line tools from any of these products, please 
make sure that the PATH, LIB, and INCLUDE environment variables are set up correctly 
for the product you are using. You can apply the Intel Fortran ifortvars.bat file from 
the …\compiler80\ia32\bin directory to set the environment to build IA-32 
executables or apply the ifortvars.bat from the …\compiler80\Itanium\bin 
directory to build Itanium-based executables.  To use Compaq Visual Fortran from the 
command line, you can select “Fortran command prompt” from the Compaq Visual 
Fortran program folder. To use Intel Visual Fortran from the command line, you can 
similarly select the appropriate Intel Visual Fortran compiler from the Intel Visual 
Fortran program folder. 
 
Using the Microsoft Visual Studio* .NET* Development Environment  
 
You can use Intel Visual Fortran within the Microsoft Visual Studio .NET development 
environment to develop Fortran applications, including static library (.LIB), dynamic link 
library (.DLL), and main executable (.EXE) applications. 
 
When using the Microsoft Visual Studio .NET development environment, you can only 
build applications for IA-32 Windows* systems. 
 
Although Intel Visual Fortran Compiler 8.1 also supports Microsoft Visual Studio .NET 
2003, examples in this section show the screens associated with Visual Studio .NET 
2002. Visual Studio.NET 2003 and Visual Studio .NET 2002 can co-exist on the same 
system. 
 

Caution: If you open an existing solution in Visual Studio .NET 2003 and 
convert it to the new environment, you can no longer open that solution with 
Visual Studio .NET 2002. If you need to use your solutions in the Visual Studio 
.NET 2002 environment on the same or a different system, you should make 
backup copies of your solution directories before opening the project(s) with 
Visual Studio .NET 2003. 

Mixed-Language Programming and Intel Visual Fortran Project Types 
 
This version of Intel Visual Fortran produces only unmanaged code, which is 
architecture-specific code. You cannot create an Intel Visual Fortran main program that 
directly calls a subprogram implementing managed code. To call managed code, you can 
call an unmanaged code subprogram in a different language that does support calling 
managed code.   
 
When using the Microsoft Visual Studio .NET development environment, Intel Visual 
Fortran supports the following project types: 
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• Console applications: the Intel Visual Fortran main program supports character 
cell output in a terminal-like window. 

• QuickWin applications: the Intel Visual Fortran main program supports certain 
graphical output. 

• Windows applications: the Intel Visual Fortran main program supports Win32 
application programming. 

• Static library applications: the .LIB file is used as a subprogram to another main 
program. 

• Dynamic link library applications: the .DLL file (and its import library) is used as 
a subprogram to another main program. 

 
For more information about Intel Visual Fortran project types, see Understanding Intel 
Visual Fortran Project Types. 
 
An Intel Visual Fortran program can be a main program and call Intel Visual Fortran 
subprograms, including Intel Visual Fortran static and Intel Visual Fortran dynamic link 
libraries.  
 
Similarly, Intel Visual Fortran can be called by Intel C++ main programs and can call 
Intel C++ subprograms, if the appropriate calling conventions are used (see the Intel® 
Visual Fortran Compiler for Windows* Systems User’s Guide).  
 
Depending upon the language used, you can use Intel Visual Fortran dynamic link 
libraries or Intel Visual Fortran static libraries as subprograms in certain mixed-language 
applications (see the Intel® Visual Fortran Compiler for Windows* Systems User’s 
Guide). 
 
For information about converting Compaq* Visual Fortran mixed-language applications 
to the Microsoft Visual C++.NET environment, see Understanding Compatibility with 
Compaq* Visual Fortran. 
 

Understanding Solutions and Projects 
 
The Microsoft Visual Studio* .NET* development environment consists of one or more 
projects contained within a solution. For example, if you have several Fortran 
applications that do different calculations but are related to the same research application 
you are working on, you can store all the individual projects in a single solution.  
 
If you are familiar with Microsoft Visual C++ 6 or with Compaq Visual Fortran, instead 
of opening a project workspace file (.dsw or .dsp) to access an existing project(s), you 
open a solution file (.sln) in the Microsoft Visual Studio .NET development environment.  
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How to Start and Exit the Microsoft Visual Studio .NET Environment  
 
From the Microsoft Visual Studio .NET program folder, click Microsoft Visual Studio 
.NET: 
 

1. From the Start menu, click Programs, then Microsoft Visual Studio .NET 
2. Click Microsoft Visual Studio.NET 

 
The Microsoft development environment window appears. 
 
To exit, close all open solutions and files, and then click Exit from the File menu. 

Visual Development Environment Windows 
 
After you start the Microsoft Visual Studio .NET environment, a window similar to the 
following appears: 
 

 

This screen shows that the Solution named Console2, the Project named 
Console2, and the source file Console2.f90 have been opened. The right pane 
shows the file Console2.f90 opened in the default language-sensitive visual 
development environment text editor, which uses different colors to identify the 
following:  
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• Source comments (green) 
• Fortran standard language elements (blue) 
• Other language text (black) 

The left pane shows the Solution Explorer window, which lets you view different aspects 
of your solution, such as the source files in your solution. The tabs displayed with the 
Solution Explorer window vary depending upon the products installed. Intel Visual 
Fortran only uses the Solution tab. To display the Solution Explorer window, in the View 
menu, click Solution Explorer (View > Solution Explorer). 
 
To edit a file listed in the Solution pane, either double-click its file name or click File > 
Open. 
 
The bottom of the right pane shown above also shows the output window, where 
compilation and linker messages are displayed. The tabs displayed with the Output 
window vary depending upon attributes associated with the current Solution and the 
windows you have elected to display. This bottom-right pane also has tabs for a Task list 
and a Command Window. The Output window displays build output, such as compiler 
and linker messages. To display the Output window, click: View > Other Windows > 
Output. 
 
The appearance of windows in the visual development environment also depends upon 
the preferences that may have been chosen from the “My Profile” option on the start 
page. To display the start page, click Help > Show Start Page. Click the My Profile link 
in the left pane. In most cases, specifying the profile of a Visual C++ developer is 
preferred for Intel Visual Fortran users. You can customize your window layout in the 
Visual Studio .NET environment (see the section “Arranging Windows” in the Microsoft 
Visual Studio .NET documentation). 

Understanding Intel Visual Fortran Project Types 

Development is organized into projects consisting of the source files required to 
build an application. To set up a project, you need to define the project and set 
options for it. Then, using the source files, you can build the binary executable or 
library file. The output of building the application becomes part of the project. A 
project is stored in a project folder on your hard drive.  

Intel Visual Fortran projects can be a main program, or they can be a subprogram 
in the form of a static or dynamic link library. 

If the Intel Visual Fortran project is a main program, it must be one of the 
following project types:  

• Console application. When you run a Fortran Console application, it 
displays a single character-cell terminal window. The programming 
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complexity for a Console application is simple, since the output resembles 
character-cell applications (no graphics). 

• QuickWin application. When you run a Fortran QuickWin application, it 
displays as multiple windows with graphics such as menus, charts, and 
icons. Programming complexity ranges from simple to moderate, 
depending on the graphics and user interaction used. 

• Windows application. A Windows application provides full access to the 
Win32* APIs, giving you a larger (and different) set of functions to work 
with than QuickWin projects. The programming complexity for Windows 
applications is typically more complex than with Console or QuickWin 
applications. 

If your Intel Visual Fortran project is a subprogram that is linked into a main 
program written in Intel Visual Fortran, Intel C++, or one of the other supported 
Visual Studio .NET languages, it must be one of the following project types: 

• Static Library application. A static library (file extension .LIB) is a set of 
routines that are loaded into your application at link time.  

• Dynamic-Link Library (DLL) application. A DLL (file extension .DLL) is 
a set of routines that are loaded into your application at run time.  

You need to create a separate project for each binary executable or library file to be 
created. A single solution can contain multiple projects, such as an Intel Visual Fortran 
Console main program and an Intel Visual Fortran Static library. 

How to Create a New Project  
 
You can create a new Intel Visual Fortran project by choosing one of the Fortran project 
types. To create a new project click File > New > Project. A window resembling the 
following appears: 
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To create an Intel Visual Fortran project, do the following: 
 

1. Click Intel® Fortran Projects in the left pane (as shown above) to display the Intel 
Visual Fortran project types. 

2. Click the appropriate project type. 
3. Accept or specify a project name (shown above as Console1). 
4. Accept or specify the Location for the project directory. 
5. Click the OK button. To assist you with project creation, Intel Visual Fortran 

provides an Application Wizard. 
 
An Application Wizard window appears for the selected project type. For Console, 
Dynamic Link Library, Static Library, and Windows application projects, the Application 
Wizard window lets you select options for creating the project. For example, when you 
create a Console project, click Application Settings in the left margin to display 
the Application Wizard options. 
 
Once you click the OK button, the project and its files appear in the Solution Explorer 
window.  Some typical tasks you can perform include: 
 

• Close a solution: click: File > Close Solution 
• Open a solution, click one of: 

o File > Recent Projects > solution-name  
o File > Open Solution 

• Open a file in the text editor, use one of: 
o Double-click the file name in Solution Explorer  
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o Click File > Open > File (for files not in a project) 
• Create a new file and add it to the project: click Project > Add New Item 
• Add an existing file to the project: click Project > Add Existing Item 
• Build the entire solution: click Build > Build Solution 
• Build the project: click Build > project-name 
• Rebuild the entire solution: click Build > Rebuild Solution 
• Rebuild the project: click  Build > Rebuild project-name 

 
Other tasks include: 
 

• Insert a debugger breakpoint: Either click in the left margin of the text editor 
window or use the Breakpoints tab 

• Display or hide the Breakpoints tab: click Debug > Windows > Breakpoints 
• Start the debugger: click  Debug > Start  
• Stop the debugger: click Debug > Stop Debugging 
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How to Set Configuration Options 
 
You can set the compilation and related options for the current configuration by doing the 
following: 
 

• Select the project name in the Solution Explorer (the project name Console1 in 
the sample screen below). 

• As shown in the sample window below, right-click the project name and select 
Properties from the pop-up menu. Alternatively, select the project name and in the 
Project menu, click Properties. 

 
Intel Visual Fortran also lets you specify compiler options for individual source files. 
Select the file name and click View > Property Pages. 
 

 
 
To display the Fortran compiler option categories, click the Fortran folder in the left 
pane. The following sample screen shows the compiler options in the General category in 
the right pane. The selected option within the General category is Suppress Startup 
Banner (value is Yes). Help for this option appears in the bottom of the pane, including 
the command-line name of the compiler option, which in this case is /nologo. 
 

 5-10



 
 
To change the setting for a compiler option, click the option’s line to display a button 
near the end (right) of the line. For example, in the sample window above, the pointer is 
positioned near the down arrow for a drop-down list for the Suppress Startup Banner 
option. Click the button at the right of an option line (as shown above) to display the 
available selections or display a dialog box. 
 
To change the configuration (such as from Debug to Release), click the Configuration 
Manager button in the upper-right of this window.  
 
Some of the Intel Visual Fortran compiler options appear in multiple categories.  
 
Options not listed in one of the categories can be typed into the Command Line category 
window under Additional Options box. For a description of these options, see the 
Intel® Visual Fortran Compiler for Windows* Systems User’s Guide. 
 
Using Debuggers 
 
To debug applications created for IA-32 systems, most users prefer to use the integrated 
Microsoft Studio .NET* debugger. Users who are very familiar with the Intel® Debugger 
(idb) or who only use the command line can use the Intel Debugger. 
 
To debug applications created for Itanium-based systems, use the Intel Debugger. 
 
The program should be compiled with the /Zi and /Od options or by selecting a Debug 
configuration in the visual development environment. The /Od option disables most 
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optimizations, which often makes debugging easier. For cases where a problem does not 
occur or cannot be isolated with the /Od option, specify the /Zi option with a higher 
optimization level (such as /O1 or /O2) instead of /Od. 

Using the Microsoft Visual Studio* .NET* Debugger 
 
To debug applications created for IA-32 Windows* systems, you can use either the Intel 
Debugger or, if the application was created using the Microsoft Visual Studio .NET 
development environment, you can use the Microsoft Visual Studio .NET debugger. 
 
Before you debug an application, open its Solution from the File menu (File > Open 
Solution). 
 
Build the project by clicking Build or Rebuild from the Build menu. If compilation or 
linker diagnostic messages appear in the Output window indicating source-related errors, 
fix the cause of the problem and rebuild the application until it builds successfully. To go 
to the source code associated with a diagnostic message in the Output window, double-
click the line associated with the message in the Output window (or click the line with the 
message and press the F4 key). 
 
To set breakpoints and control program execution: 
 

• To set a breakpoint, click in the left margin next to the source where you want to 
set or remove a breakpoint. A filled-in red circle appears. 

• To start the debugger, click Start in the Debug menu. The program executes and 
stops at the first breakpoint. 

• You can Step Over the current statement (Step Over item in the Debug menu, or 
click the Step Over button on the Debug toolbar). 

• You can Step Into a routine or Step Out of a routine using the Debug menu or the 
Debug toolbar. 

 
To control the appearance of the debugger-related panes, in the Debug menu, click 
Windows and select the appropriate window, such as Breakpoints. For example, the 
Breakpoints window (appears as a tab near the Output window by default) allows you to 
disable or enable a breakpoint. 
 
To restart execution of the application being debugged, click Restart in the Debug menu. 
 
To stop debugging, click Stop Debugging in the Debug menu. 
 
For more information about using the Visual Studio .NET* debugger, see the debugging 
section in the Intel® Fortran Compiler for Windows Systems User’s Guide. 
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Using the Intel Debugger (idb) 
 
To start the Intel® Debugger and load a program for debugging: 
 

1. In the Intel® Software Development Tools program folder, click Intel® 
Debugger 8.1 > Intel Debugger. 

2. On the command line, type the command idb and the name of the executable 
program to be debugged. 

 
For more information, please refer to the online manual for the Intel Debugger or the 
debugging section in the Intel® Fortran Compiler for Windows Systems User’s Guide.  
 
To exit your program, type the exit command. 
 
Using the Intel® Array Visualizer  
 
The Intel® Array Visualizer allows you to display and graph array data. Application 
programs can use the following methods to control the displayed graphs and data grid: 
 

• Library API routines  
• ActiveX* controls 
• Object model properties, methods, and events 

 
The Intel Array Visualizer library routines allow Fortran and C++ applications to access a 
subset of the extensive object model by using traditional library routine API interfaces 
that are easier to use than ActiveX controls or object model interfaces. 
 
The Intel Array Visualizer object model is a set of reusable objects that provide access to 
Intel Array Visualizer features and functionality. The COM interface supports an 
extensive object model that provides methods, properties, and events that can be accessed 
from any language that supports COM objects, including Microsoft Visual Basic*, 
Microsoft Visual Basic* .NET, Microsoft Visual C++, Microsoft Visual C++ .NET, 
Microsoft Visual C#* .NET, Intel C++, and Intel Visual Fortran. 
 
Applications can also save their array data in the form of a graphics file, which can be 
read later by the Intel Array Viewer. When you install the Intel Array Visualizer, you 
also install its viewer, Intel Array Viewer. 
 
The Intel Array Viewer lets you interactively display data grids as well as various types 
of graphical plots.  Depending upon the data file selected, different attributes of the file 
will appear in the left pane. 
 
If you accepted the default directory during installation, the sample graphics data files are 
installed in: 
 
C:\Program Files\Intel\Fortran\Array Visualizer\data 
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The following figure shows the Intel Array Viewer displaying an image plot of one of the 
sample data files (file sinxy.hdf).   
 

 
 
Support for COM and Automation Objects: Fortran Module Wizard 
 
Intel® Visual Fortran provides a wizard to simplify the use of Component Object Model 
(COM) and Automation (formerly called OLE Automation) objects. The Intel Visual 
Fortran Module Wizard generates Fortran modules that simplify calling COM and 
Automation services from Fortran programs. This Fortran code lets you invoke methods 
of an Automation object and member functions of a Component Object Model (COM) 
object. 
 
To run the Intel Visual Fortran Module Wizard, select Intel® Fortran Module Wizard 
from the Tools menu in the Visual Studio.NET IDE. For more information about using 
the Intel Visual Fortran Module Wizard, see the section about the Fortran Module Wizard 
in the Intel® Visual Fortran Compiler for Windows* Systems User’s Guide, Volume I. 
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Understanding Compatibility with Compaq* Visual Fortran 
 
Intel Visual Fortran provides source compatibility with Compaq* Visual Fortran 6.6 and 
similarly provides a highly optimizing compiler that supports standard Fortran 95 and a 
common set of language extensions. Intel Visual Fortran supports most of the Compaq 
Visual Fortran command-line options as well as support for: 
 

• Fortran project types. 
• Module files for Windows API interfaces. 
• Attributes to simplify calling C/C++ routines. 

 
Some of the major differences include: 
 
• Intel Visual Fortran supports integration with Microsoft Visual Studio* .NET* 

(including Microsoft Visual C++ .NET), whereas Compaq Visual Fortran supports 
integration with Microsoft Visual Studio 98 (including Microsoft Visual C++ 6). 

• For command-line use, Intel Visual Fortran uses the ifort command and Compaq 
Visual Fortran supports the DF command.  

• Microsoft Visual Studio.NET does not support mixing Fortran and C++ source files 
in the same project. Instead, Fortran source files are placed in one project and the 
C++ source files are placed in another project. One of the projects is a static library 
project that is linked with the other project. If you open a Compaq* Visual Fortran 
project that contains mixed C++ and Fortran source code, the Intel Visual Fortran 
project converter converts this project into two projects: a C++ project and a separate 
Fortran project (see the User's Guide, Volume I for details on project conversion). 

• The names of the module interface definition files differ. For example, Compaq 
Visual Fortran required a USE DFLIB statement for certain routines; with Intel 
Visual Fortran, the USE statement might be USE IFCORE or a similar name. For 
compatibility with existing sources, Intel Visual Fortran includes additional modules 
with the same names as most of those provided by Compaq Visual Fortran. These 
additional modules invoke the new Intel Visual Fortran modules.  For faster 
compilation and future compatibility, Intel recommends converting to the new names. 

• The Intel Array Visualizer has a different program interface based primarily on a 
comprehensive object model and a different tree-based user interface. 

 
For information about converting Compaq Visual Fortran 6 project directories, see 
Copying Compaq* Visual Fortran Project Files and the Intel® Visual Fortran Compiler 
for Windows* Systems User’s Guide. 
 
For more complete information about compatibility with Compaq Visual Fortran, see the 
Intel® Visual Fortran Compiler for Windows* Systems User’s Guide. 
 
Intel Fortran Language  
 
The Intel Fortran is shared by Intel Visual Fortran for Windows* Systems and Intel 
Fortran for Linux* Systems. The Intel Fortran language is fully compliant with the 
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ISO/IEC 1539:1995 Fortran standard, usually referred to as "the Fortran 95 Standard" or 
as "Fortran 95". Intel Fortran also includes a number of extensions to the Fortran 95 
Standard, as well as command-line options that allow you to override the default actions 
of the compiler. The Intel Visual Fortran compiler provides source compatibility with 
Compaq Visual Fortran.  
 
The Intel Visual Fortran compiler allows you to obtain outstanding performance from all 
Intel 32-bit processors, including the Intel Pentium® 4, Intel® Xeon™, Intel® Pentium® 
M processors, and the Intel Itanium® processors. Through the use of unique compiler 
optimizations, such as support for Streaming SIMD Extensions 2 (SSE2) in the Intel 
Pentium 4 processors and software pipelining in Intel Itanium processors, the Intel Visual 
Fortran compiler can deliver strong performance improvements. Using features such as 
Interprocedural Optimization and Profile-Guided Optimization can further improve 
application performance.  
 
For more information, refer to the Intel Visual Fortran documentation (see Chapter 6). 
 
Using the IMSL* Libraries 
 
The Intel® Visual Fortran Compiler 8.1, Professional Edition, for Windows* includes the 
IMSL* Libraries, which is a collection of nearly 1,000 mathematical and statistical 
functions easily accessible from the visual and command line development environments. 
The IMSL* Libraries are provided in both static library and dynamic-link library (DLL) 
forms, each available in a single-processor and multiprocessor-enabled version.  
 
The following table lists the IMSL* Libraries included in the Professional Edition of Intel 
Visual Fortran compiler. 
 

File Name Library Description 
IMSL IMSL* static library, contains FORTRAN 77 and Fortran 90 

routines 
IMSL_ERR IMSL* error handler library 
IMSLMPISTUB Stub library for MPI routines used in IMSL* 

 
You can find detailed information about working with the IMSL* Libraries in the Using 
the IMSL* Mathematical and Statistical Libraries topic of the Intel® Visual Fortran 
Compiler for Windows* Systems User’s Guide, Volume I: Building Application. 
Additionally, you can view the IMSL* readme file and online help using the IMSL* 
Fortran Library 5.0 program folder. The online documentation included with the IMSL* 
Libraries includes text files and PDF files; the documentation includes all of the 
information you will need to understand and use the IMSL* Libraries. 
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Interface Definitions for Library Routines 
 
Intel Visual Fortran provides interface definitions to certain external routines, including 
Intel Visual Fortran library routines, Intel Array Visualizer library routines, and certain 
Win32 routines. 
 
Please refer to the beginning of the appropriate chapter in the Intel® Fortran Libraries 
Reference for interface blocks or USE statements needed for certain groups of library 
routines. For example, to call certain Portability routines, add the statement line USE 
IFPORT, which reads the precompiled ifport.mod file in the …\INCLUDE directory. 
 
For information on calling Win32* routines (IA-32 systems only) using the Intel Visual 
Fortran interface definitions, see the Intel® Visual Fortran Compiler User’s Guide. 
 
For information about calling the Intel Array Visualizer routines, refer to the Intel Array 
Visualizer online documentation. 
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6 Documentation Road Map 
 
Intel® Visual Fortran and Intel® Array Visualizer provide online documentation in 
multiple formats: 
 

• Microsoft HTML Help CHM format 
• Adobe Acrobat* PDF format 
• HTML or HTML-based files 

 
Accessing the Intel® Visual Fortran Documentation Index 
 
To access the Intel® Visual Fortran documentation, open the Intel Visual Fortran 
documentation index in the Intel Visual Fortran program folder. To display the Intel 
Visual Fortran program folder: 
 
Start > Programs > Intel® Software Development Tools > Intel® Fortran Compiler  
 
Alternatively, you can open the file fcompindex.htm (in the File menu, click Open, 
click the Browse or Choose File button). The fcompindex.htm file is located in the 
CD-ROM root directory and is installed in the Intel Visual Fortran 
…\Compiler80\Docs directory. 

Intel Visual Fortran Documentation in HTML Help Viewer Format 
 
The Intel® Visual Fortran online help consists of the following documentation: 
 

• The Intel® Visual Fortran Compiler for Windows* Systems User’s Guide, 
Volume I: Building Applications describes the Intel Visual Fortran compiler, 
including the ifort command, and the various compiler options for IA-32 and 
Itanium®-based systems. It contains sections that describe new features for this 
release, using the command line environment, using the IDE environment, 
customizing the compilation environment and process, mixed language 
programming with C++, understanding libraries, and understanding error 
messages.  

• The Intel® Visual Fortran Compiler for Windows* Systems User’s Guide, 
Volume II: Optimizing Applications describes the comprehensive set of features 
available to optimize applications for optimal run-time performance, including 
command-line options, vectorization (on IA-32 systems), parallel processing 
using OpenMP*, timing and profiling applications, coding guidelines, and using 
optimization-related directives and intrinsic procedures. 

• The Intel® Visual Fortran Compiler for Windows* Systems Options Quick 
Reference Guide provides an alphabetical listing of ifort command-line 
options, with links to the sections in the User Guides where the options are 
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described in more detail. It also includes a list of new options, as well as a list of 
Compaq Visual Fortran compatibility options. 

• The Intel® Fortran Language Reference describes the Intel Fortran language and 
available library routines. This HTML Help document includes the material found 
in the Intel® Fortran Language Reference and the Intel® Fortran Libraries 
Reference PDF files. This topic also includes an A-to-Z summary of all Intel 
Visual Fortran intrinsics, statements, library routines, and directives. The 
description of each library routine includes the USE statement needed to include 
the interface definitions needed to call that routine.  

 
HTML Help files have multiple tabs, including Contents, Index, and Search tabs. Here 
are some tips related to using the Search tab: 
 

• To locate multiple adjacent words, enclose the words within quotation marks. 
• After typing the search string, click the List Topics tab to display a list of 

topics that match the search string. 
• You can either double-click one of the topics listed to display its contents, or 

select the topic and click the Display button. 
• Buttons in the lower-left area let you select whether to search previous results, 

match similar words, or search titles only 

Intel Visual Fortran Documentation in PDF Format  

The Intel® Fortran Language Reference describes the Intel Fortran programming 
language, including intrinsic procedures. This document describes Intel Fortran language 
elements and visually identifies Intel Fortran extensions to the Fortran 95 standard. This 
document applies to Intel Visual Fortran for Windows* Systems and Intel Fortran for 
Linux* Systems. This document is also available in hardcopy printed form. 

The Intel® Fortran Libraries Reference describes the library procedures in the various 
Intel Fortran libraries and provides an alphabetic listing of the library routines. This 
document applies to Intel Visual Fortran for Windows* Systems and Intel Fortran for 
Linux* Systems. 

The Intel® Visual Fortran Compiler for Windows* Systems Installing and Getting 
Started is the guide you are now reading. 
 
Using the Intel® License Manager for FLEXlm* describes how to install and use the 
Intel(R) License Manager for FLEXlm* to configure a license server for systems using 
counted licenses. This document is available from the Intel® License Manager for 
FLEXlm* program folder. 
 
To read these documents, you must have installed Adobe* Acrobat* Reader (or Adobe* 
Acrobat*) Version 4 or later.  
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Intel Visual Fortran Documentation in HTML Format 
 
The Enhancing Performance with Intel® Compilers provides an interactive HTML-based 
tutorial on using compiler options that help you optimize your application for IA-32 and 
Itanium-based systems. To view this tutorial, select Tutorial from the Intel Visual Fortran 
Compiler program folder. You can also display this tutorial by selecting the link for 
Compiler Performance Tutorial from the Documentation index (see Understanding the 
Intel® Visual Fortran and Intel Debugger Program Folders). 
 
The release notes for Intel Visual Fortran describe the latest information about the Intel 
Visual Fortran compiler. To view the release notes, select Release notes from the Intel® 
Visual Fortran Compiler program folder. 
 
Accessing the Intel Array Visualizer Documentation Index 
 
To access the Intel Array Visualizer documentation, open the Intel Array Visualizer 
documentation index in the Intel Array Visualizer program folder. To display the Intel 
Array Visualizer program folder, click: 
 
Start > Programs > Intel® Software Development Tools > Intel® Array Visualizer   
 
Alternatively, you can open the file avindex.htm (in the File menu of a Web browser, 
click Open, then click the Browse or Choose File button). The avindex.htm file is 
located in the CD-ROM root and is installed in the …\Array Visualizer\Docs 
directory. 

Intel Array Visualizer Documentation in HTML Help Viewer Format  
 
Intel Array Visualizer documentation in online HTML Help format includes the Intel 
Array Visualizer online reference documentation and the Intel Array Viewer online 
documentation. 
 
The Intel Array Visualizer online documentation provides detailed information for the 
software developer about the Intel Array Visualizer: 
 

• Object model, including methods, properties, and events. 
• ActiveX* controls. 
• Library routines. 

 
The Intel® Array Viewer online documentation provides information about the Intel 
Array Viewer user interface. To view the Intel Array Viewer online documentation, click 
Help Topics in the Intel Array Viewer Help menu. 
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Intel Array Visualizer Documentation in HTML Format 
 
The release notes for Intel Array Visualizer describe the latest information about Intel 
Array Visualizer software. To view the Intel Array Visualizer release notes, select 
Release notes from the Intel Array Visualizer documentation index. 
 
Printed Documentation 
 
In addition to the online PDF file, the Intel® Fortran Language Reference is available in 
printed (hardcopy) form. To order this document, contact your reseller or see the Intel 
Visual Fortran product Web pages at: 
 
http://developer.intel.com/software/products 
 
Other Documentation 
 
To access the Intel® Debugger online documentation (HTML format), open the 
Documentation item from the Intel® Debugger program folder. 
 
Other documentation files may be installed, such as the help files for tools. To access the 
help file for a tool, choose the appropriate item (such as Help Topics) from the tool’s 
Help menu. 
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7 Intel® Visual Fortran Technical Support 
 
Intel® Visual Fortran provides technical support primarily through your Intel® Premier 
Support account and related web site. 
 
Accessing Your Intel® Premier Support Account 
 
If you purchased an Intel Visual Fortran download package, you are automatically 
registered and can access your Intel® Premier Support account with the account 
information you obtained when you purchased the downloaded version of Intel Visual 
Fortran. 
 
If you purchased the Intel Visual Fortran CD-ROM version, register your purchase and 
activate your Intel Premier Support account by opening the following internet URL in a 
Web browser: 
 
http://www.intel.com/software/products/registrationcenter/ 
 
In addition to your name and related information, you need to provide the registration key 
(serial number) supplied with your Intel Visual Fortran CD-ROM package. Remember 
your username and password for your Intel Premier Support account, so you can obtain 
product updates and access technical support information. A new license file will be sent 
to you by email, which you should copy to your license directory (see Activating the 
License File in Chapter 2).  
 
If you already have access to an Intel Premier Support account, register your new 
purchase at the Registration Center to obtain a new license file(s) and be eligible for 
support and updates.  
 
Once you have registered and obtained an Intel Premier Support User name and 
Password, you can access your Intel Premier Support account using a secure web site at: 
 
https://premier.intel.com/ 
 
Your account lets you access timely compiler support information, including top known 
technical issues, software updates, FAQs, and other information. If you have trouble 
accessing the Intel Premier Support Web site, you can send email requesting assistance to 
the following email address: developer.support@intel.com. Do not send 
descriptions of technical issues or other email to this account, since it is not a secure 
connection. 
 
Guidelines for Reporting Problems  
 
Before you report a potential problem, please use the following guidelines: 
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• Narrow down the problem to a small set of source code that reproduces the 
problem. 

• Provide the exact error message that appears and when it appears. 
• Indicate the compiler options used to reproduce the problem and any knowledge 

about which options are most relevant to the potential problem.  
• You can use the Intel information reporter tool to gather system information, save 

it to a .TXT file for later use. If you need to submit an issue using your Intel 
Premier Support account, you can attach the saved .TXT file to the issue.  

• To obtain the compiler package version, execute the compiler. For example, using 
the ifort command displays the package version. 

• Make sure your Intel Premier Support contact information is correct, especially 
your email address. 

 
Using the Intel® Information Reporter Tool  
 
The Intel® information reporter is a tool installed with Intel Visual Fortran that gathers 
system data from your Windows* system (such as relevant registry information, 
environment variables, operating system name and version, and compiler information) 
and writes it into an ASCII text file that can be attached in an email to Intel Technical 
Support. 
 
The Intel information reporter tool is installed automatically with Intel Visual Fortran and 
is an entry in the Intel Visual Fortran Compiler program subfolder. When you click Intel 
information reporter in the program folder, a screen resembling the following screen 
appears: 
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Although the Intel information reporter tool is primarily used to gather and provide 
information to Intel Technical Support, you can use this tool to capture information about 
your system at various times.  
 
Click a tab to view its contents.  The buttons at the bottom of the screen let you perform 
the following functions: 
 

• To print this information to a printer, click the Print button. Select the 
appropriate printer and printer job options. 

• To save the captured information to a plain ASCII .TXT file, click the Save 
button. Choose an appropriate directory and file name to save the file. The saved 
file path and name is also placed in your clipboard. 

• To access the Premier Support Web site so you can log in, click the Premier 
Support button. 

• To discontinue using the Intel information reporter tool, click the Exit button. 
 
If you need to submit an issue using your Intel Premier Support account, you can attach 
the saved .TXT file to the issue.  
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